AR15.Com Archives
 Cetme firing problem
BruceWayne  [Member]
2/11/2004 10:37:44 PM EST
I have a friend who owns a cetme rifle. It shoots factory .308 ammo fine, such as Remington Core-Lokt. When he goes to fire mil surplus, it will fire the first round and then stop. The primer is slightly dented. Could this be just a firing pin or spring problem, or might it be to large a headspace?

The surplus ammo was Australian and something made in India I believe.

Thanks for any replies and I hope this in the correct forum.

Bruce Wayne
Paid Advertisement
--
AR18  [Member]
2/12/2004 3:56:29 PM EST
It could be a hard primer on the surplus ammo.
BobCole  [Team Member]
2/13/2004 12:26:15 PM EST
Sounds like the mil-surp may not be fully chambered. Could be the gas adjust isn't the same for both types of ammo & may need more or less zip to work the mil-surp.

Try that & then see what happens.
motopix  [Team Member]
2/15/2004 3:31:36 AM EST

Originally Posted By BobCole:
Sounds like the mil-surp may not be fully chambered. Could be the gas adjust isn't the same for both types of ammo & may need more or less zip to work the mil-surp.

Try that & then see what happens.



Gas adjust? On a CETME?

So the rifle is chambering the second round and that round shows a light primer strike after the trigger is pulled?

Is bolt locking into battery?

You might try you question on the CETME forum
www.gunboards.com/forums/forum.asp?FORUM_ID=47

And check the headspace before you fire it again!
BobCole  [Team Member]
2/15/2004 8:46:48 AM EST

Originally Posted By motopix:
Gas adjust? On a CETME?




Are they not like a FAL gas adjust? Or are they like the G3 & auto?
motopix  [Team Member]
2/15/2004 8:54:15 AM EST


Are they not like a FAL gas adjust? Or are they like the G3 & auto?



There is no adjustment for gas. It's a roller-locking mechanism.
BruceWayne  [Member]
2/15/2004 9:02:59 PM EST
Thanks for the replies. The rifle would fire the first shot, then have a light strike on the second. But...he also tried loading 1 round at a time and some of those would not fire--they also had a mark on the primer.

I will go ahead and post on that CETME forum--thanks again.

Bruce Wayne
lokt  [Team Member]
2/15/2004 9:20:07 PM EST

Originally Posted By BruceWayne:
Thanks for the replies. The rifle would fire the first shot, then have a light strike on the second. But...he also tried loading 1 round at a time and some of those would not fire--they also had a mark on the primer.

I will go ahead and post on that CETME forum--thanks again.

Bruce Wayne



Headspace???
WarDawg  [Member]
2/16/2004 5:03:20 AM EST
Something to check. The hammer spring. I broke mine in my CETME and it would fire about 50% with a broken spring. Military surplus. The trigger should have a sharp snap to it. If its slow and slugish, replace. WarDawg
G-CODE  [Team Member]
2/19/2004 4:05:41 AM EST

Originally Posted By lokt:


Headspace???



BOLT GAP!


www.hot51.com/headspace.htm
Paid Advertisement
--